Echo JS 0.11.0


amitport comments

amitport 93 days ago. link 1 point
I wouldn't take that comment too seriously... IMO, it is a cool, well coded/documented project :)
amitport 100 days ago. link 1 point
OK. I also noticed that '' was updated. Things are getting a little clearer, will give it a try, thanks :)

(Still, IMO, you may want to mention the providers abstraction (/SPI?) with specific examples early in the introduction. For me, this seems like the most meaningful unique (AFAIK) capability)
amitport 102 days ago. link 1 point
hmmm... I must be missing something. How does this help with reproducible deployments?
amitport 108 days ago. link 5 points
(-) requires training - this syntax may be unfamiliar/confusing to some people
(-) over-use is very bad - the problems are mentioned in MDN.
(+) when used exactly right - it saves a few characters

IMO, when working in a company/team/open-source-project it's just not worth the effort and risk (of over-use).

You can do something like this instead (a little more verbose but more readable for humans and compilers):
  const {loadEventEnd, navigationStart} = window.performance.timing;
  console.log(loadEventEnd - navigationStart);
amitport 157 days ago. link 3 points
redux abstracts a few basic patterns that are common in big apps. Its popularity fostered a very interesting ecosystem.

It's a tool. It's worth learning.

I don't see the point of attacking it or religiously adding it to any project.