Echo JS 0.11.0


amitport comments

amitport 201 days ago. link 5 points
(-) requires training - this syntax may be unfamiliar/confusing to some people
(-) over-use is very bad - the problems are mentioned in MDN.
(+) when used exactly right - it saves a few characters

IMO, when working in a company/team/open-source-project it's just not worth the effort and risk (of over-use).

You can do something like this instead (a little more verbose but more readable for humans and compilers):
  const {loadEventEnd, navigationStart} = window.performance.timing;
  console.log(loadEventEnd - navigationStart);
amitport 250 days ago. link 3 points
redux abstracts a few basic patterns that are common in big apps. Its popularity fostered a very interesting ecosystem.

It's a tool. It's worth learning.

I don't see the point of attacking it or religiously adding it to any project.
amitport 267 days ago. link 1 point
Very nice, but it's important to note that it is released under AGPL. AFAIK, it means that almost every usage of this code, including as part of a web-api, can be required to be released as open source under the same license.
amitport 283 days ago. link 2 points
"Add support for ESM. This is currently behind the --experimental-modules flag and requires the .mjs extension. node --experimental-modules index.mjs" 👍
amitport 402 days ago. link 1 point
clicking 'getting started' just says to come back in a few months— whatever it is, it hasn't arrived...
amitport 405 days ago. link 1 point
There are ISec companies that maintain this kind of lists as part of their main business. They test against penetration tools and review against all CVEs. I worked in such a company, but unfortunately, I don't remember specific patterns and couldn't disclose any if I did.

I know I'm not being extremely useful. In any case, I think it is important to clearly state that companies with critical security requirements should probably not rely solely on this.
amitport 405 days ago. link 1 point
Nice, but the rules are somewhat minimal IMHO. It will be nice to mention that in the readme.