Echo JS 0.11.0


kornflexx comments

kornflexx 6 days ago. link 1 point
As an utility function you have to make it faster as possible, the array prototype that you are using are much slower than "low level" iterators.

this: Object.keys(option).forEach
should be: for (const key in option)

You are coupling your lib with React (only by the name), but it can be used outside react.

The strangest thing on your lib is that:
  [1 + 2 === 3]: ['apple', 'pie']
}) // output -> 'apple'

Use a boolean as an object key is a bad practice: you can't use two conditions key/value.

  [1 + 2 === 3]: ['apple', 'pie'],
  [1 + 2 === 3]: ['sand', 'earth']
}) // output -> 'sand'

You have to use two objects to make it works.
kornflexx 50 days ago. link 2 points
It's pretty cool that you tried to make your own library but I am not sure it have its place here.

You look beginner, so I will give your some advices.

your props called "changeCurrentStep" is an event, so it should be prefix by "on". Because you have only one controlling props "currentStep" I think a simple "onChange" will fit right as a name for this callback.

Don't forget the prop classname that have to be passed to the wrapper (in your render method).

In your stepper component don't use "componentWillReceiveProps" (it is deprecated now). Use getDerivedStateFromProps instead.

I am pretty sure your code throw warning if you don't have style props set. (Not sure if '' is a valid value, I think it throw a warning if you don't put an object).

You should keep learning before thinking about publishing library on npm.
kornflexx 130 days ago. link 1 point
So why put redux in the name ? How a reducer can be a reducer if he is not called on reduce callback ?(for the size issue, you can use redux as a peer dependency).

I think that "redux" name part is too much.

Your concept is really good, and your code is excellent, why not choosing your own name ?

I see that you have implemented reduxsauce api (that is cool too).

In fact the whole thing look like hyperapp actions/state API. 

I have the same frustration of writing class for my components.
kornflexx 131 days ago. link 1 point
Why did you rewrite redux instead of import it ? From what I read your lib can be 20 lines of codes length...
kornflexx 184 days ago. link 1 point
Couple this with react-virtualized to improve perf :)
kornflexx 187 days ago. link 1 point
This article is a big hoax. It clearly says, in react native, that you need a codebase for Android and another one for iOS...
kornflexx 187 days ago. link 1 point
Should ban the user and the ip, he make a post every day...